Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Chapter 7: Pickers - Audio for Custom Picker

Having issue getting the sounds to play for the Custom Picker. 

 I have:  (1) verified my code to make sure it corresponds to what is in the book, 
              (2) am importing the AudioToolbox (import AudioToolbox), and 
              (3) have added the Framework to my project (below). 

Not sure what else to do. I have an older MacMini with 2gb RAM. 

Thanks in advance for any help going forward.

image

Comments

  • I have the same issue.

    I also tried the sample code that comes with the book and this doesn't seem to play sounds either, so I'm guessing that it's something to do with the iOS Simulator.

    Have you tried running the app on on actual iPhone / iPad?  I can't at the moment as mine's being repaired

    Regards

    Matt
  • The sound doesn't seem to work in the simulator but it does on my iPhone. However, my app seems to get stuck when it wins a 2nd time. Anyone else have that issue?
  • Chapter 7: All tabs are running as expected on the Simulator, except the Custom Picker.
    I up to now cannot run the app on may iPhone.

    The Custom Picker too runs as expected, but it does NOT play any sounds!

    When I double-click the WAV-files in the Pickers directory, I get the sounds.

    Is this a bug in the Simulator?

    I am on Xcode 6.1.1



  • Just to make sure--- everyone with problems DID add the actual sounds to the PICKERS folder inside XCode? And not simply add the file to the directory on their computer? 
Sign In or Register to comment.